Couldn't import dot_parser问题的解决

最近给新进的两台Tesla K40工作站装Theano环境,发现它的依赖——pydot在import的时候总会出现一个Couldn't import dot_parser的错误。

谷过之后发现是dot_parser的依赖pyparsing的版本太高了,而dot_parser一直没修正,所以出现了这些问题。

解决方法很简单,把pyparsing降级到2.0一下就行,代码:

pip uninstall pyparsing  
pip install -Iv https://pypi.python.org/packages/source/p/pyparsing/pyparsing-1.5.7.tar.gz#md5=9be0fcdcc595199c646ab317c1d9a709  
pip install pydot  

Friskit

继续阅读此作者的更多文章